Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7194 closed bug (duplicate)

DatePicker year select dropdown has only one entry with multiple months showing

Reported by: kbwood Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

Ref: http://forum.jquery.com/topic/datepicker-year-select-dropdown-has-only-one-entry-with-multiple-months-showing.

This has been caused by the deferred update of the year drop-down to avoid flashes on Firefox.

Solution: wrap the generation of the inst.yearshtml property in _generateMonthYearHeader to only do it once.

		// year selection
		if (!inst.yearshtml) {
			inst.yearshtml = '';
			...
				//when showing there is no need for later update
				if( ! $.browser.mozilla ){
					html += inst.yearshtml;
					inst.yearshtml = null;
				} else {
					// will be replaced later with inst.yearshtml
					html += '<select class="ui-datepicker-year"><option value="' + drawYear + '" selected="selected">' + drawYear + '</option></select>';
				}
			}
		}

Change History (2)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by Scott González

Duplicate of #7176.

Note: See TracTickets for help on using tickets.