Opened 11 years ago

Closed 10 years ago

#7239 closed bug (notabug)

JQuery.dialog() doesn't play well with Textarea in Firefox 4

Reported by: [email protected] Owned by: [email protected]
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.11
Keywords: Cc:
Blocked by: Blocking:

Description

Basically, Form elements under $("#fooForm") is cleared and populated before $('div.fooFormContainer').dialog({...}).show() and problem arises on textarea. It shows a previously used value, when it shouldn't. It doesn't show a value, when it should.

If clearing and population is done after $('div.fooFormContainer').dialog({...}).show() it works. And it only happens in Firefox 4 not chrome. By the way, I'm using Win 7.

Full details is listed below

http://pastebin.com/qQu7J5dr

Change History (4)

comment:1 Changed 11 years ago by Scott González

Component: ui.coreui.dialog

Sounds like a bug in Firefox.

comment:2 Changed 10 years ago by Scott González

Owner: set to [email protected]
Status: newpending

Please provide a reduced test case showing the problem. You can use jsFiddle or jsbin as mentioned in the red message box. The pastebin example can't be run and references code that doesn't exist.

comment:3 Changed 10 years ago by Mike Myat Min Han

I'm afraid I can no longer reproduce the error anymore. I will reopen this ticket when I encounter this error again.

comment:4 Changed 10 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.