Opened 8 years ago

Closed 6 years ago

#7262 closed bug (invalid)

Webkit bug: sortable table cells do not return into the right positions after sorting

Reported by: krasu-desu Owned by: krasu-desu
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

WebKit doesn't return cells into the right positions after sorting

If we look into updated inline css style we can see that is is correct, but cell freezes in its helper position

Error appears in sortable table cells. Table must have more than 1 row (if table has only 1 row, WebKit return cells into right positions)

The most simple way to reproduce it - to drag cell for more than 1 position

http://jsfiddle.net/vzZ6C/1/

http://img863.imageshack.us/img863/1667/screenshotwm.png

Tested in Chromium 10 (linux) and latest Safari for Windows

Change History (4)

comment:1 Changed 8 years ago by whittet@…

Able to reproduce. Forked jsfiddle to show minimum code to reproduce in jqueryui 1.8.12. http://jsfiddle.net/whittet/NXZjh/

comment:2 Changed 6 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 6 years ago by mikesherov

Owner: set to krasu-desu
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! I can no longer reproduce the issue using the latest jQuery and jQuery UI using the info provided. http://jsfiddle.net/whittet/NXZjh/

If you can still reproduce it, please feel free to reply to this ticket with a test case showing the problem. Thanks!

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.