Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7263 closed bug (duplicate)

Wrong position when draggable element or it's parent has transformations

Reported by: Syndikaattori Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.draggable Version: 1.8.11
Keywords: Cc:
Blocked by: Blocking:

Description

When element or it's parent has transforms, eg. rotate or scale, the element translates to wrong position when dragging using JQuery UI Draggable.

For example these examples fail (tested in Mac Chrome 10 and Safari 5):

$("#element_id").draggable();

$("#element_id").css("-webkit-transform","rotate(10deg)"); $("#element_id").css("-webkit-transform","scale(2,2)");

$("#element_id").parent().css("-webkit-transform","rotate(10deg)"); $("#element_id").parent().css("-webkit-transform","scale(2,2)");

The problematic part seems to be _generatePosition() function which returns top and left position of element, but ignores all transformations. This bug makes using UI Draggable almost impossible in many situations.

Change History (2)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by Scott González

Duplicate of #6844.

Note: See TracTickets for help on using tickets.