Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7273 closed enhancement (wontfix)

Table header style on datepicker collision

Reported by: lschreur Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.11
Keywords: Cc:
Blocked by: Blocking:

Description

I noticed a problem where the ui-datepicker style was inheriting a min-width property set on a style outside of the jQuery UI style. It displayed the datepicker calendar much wider than it was intended to be.

I resolved the problem by adding a "min-width: 0" to the specific style. I'm currently using the Smoothness (1.8.11) theme but I can image the same problem occurs on other themes as well.

The is the line I added the "min-width" property (reset) to (around line 520):

.ui-datepicker th { min-width: 0; padding: .7em .3em; text-align: center; font-weight: bold; border: 0; }

Change History (2)

comment:1 Changed 9 years ago by Scott González

Resolution: wontfix
Status: newclosed

Accounting for every possible style that someone might set seems unreasonable.

comment:2 in reply to:  1 Changed 9 years ago by lschreur

Replying to scott.gonzalez:

Accounting for every possible style that someone might set seems unreasonable.

It is far from unreasonable. And yes, you need to account for every possible style someone might set. Taken bug reports like this into account will actually help you toward reaching that goal.

Note: See TracTickets for help on using tickets.