Opened 9 years ago

Closed 7 years ago

#7278 closed bug (duplicate)

Draggable position becomes incorrect when dragging to a target that isn't visible without scrolling

Reported by: eanders Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.draggable Version: 1.8.12
Keywords: Cc:
Blocked by: Blocking:

Description

If you drag a draggable beyond the visible window the mouse cursor and draggable item become separated visually. The draggable actions follow the mouse, while the draggable item moves further and further away. If you then drop the item and attempt to pick it up again there can be significant confusion with regards to where the item actually is.

The behavior is visible in the default draggable example: http://jqueryui.com/demos/draggable/default.html

and perhaps more clearly here: http://jsfiddle.net/eanders/RvAJm/5/

This bug appears in jQueryUI 1.8.12 It has been found in Safari 5, Chrome 10, Firefox 4 It has been seen on both Mac OS 10.6 and Windows XP

Change History (2)

comment:1 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:2 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #5718.

Note: See TracTickets for help on using tickets.