Opened 8 years ago

Closed 7 years ago

#7297 closed bug (invalid)

Datepicker - month/year dropdowns require two clicks to open correctly.

Reported by: paddyboyd Owned by: paddyboyd
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.8.12
Keywords: Cc:
Blocked by: Blocking:

Description

I have recently encountered a problem in IE, using the datepicker script:

  1. Load up a page with a datepicker on it, showing both the year and month dropdowns.
  1. Select a date (this works fine first time).
  1. Open the datepicker again, but this time, when you click on one of the year/month dropdown lists, it appears briefly and then disappears, requiring a second click to get it to appear correctly.

I have a small test page (see below) and have tested this using jQuery 1.4.4 and jQuery UI 1.8.10 (my production configuration) and jQuery 1.5.2 and jQuery UI 1.8.12 and been able to reproduce it in both cases (using IE9 and also in IE6).

<head>
<script type="text/javascript"> 
   
$(document).ready(function () {        

$("#testDate").datepicker({
    changeYear:true,                        
    changeMonth:true,                     
    constrainInput:true,                    
    buttonText:'Choose',                     
    showOn:'both',                     
    showButtonPanel:false,                     
    buttonImageOnly:true});    });

</script>
</head>
<body>
    <input type="text" id="testDate" />
</body>

I think that this is a restating of a previously closed ticket 6996. I can reproduce this using the steps above and the URL stated in the closed ticket:

http://jqueryui.com/demos/datepicker/dropdown-month-year.html

Change History (5)

comment:1 Changed 8 years ago by BenjaminPaap

Just a small hint:

For me this one is reproducible when I do the following in IE8:

  1. Open the page
  2. Set the focus to the input field by clicking it
  3. Change the month value with the dropdown list
  4. Now click on the year dropdown and it should directly disappear

Another way to reproduce this is the following:

  1. Open the page
  2. Set the focus to the input field by clicking it
  3. Open the year dropdown without choosing a value and click beneath the datepicker to remove the focus from the field
  4. Reopen the datepicker and click the year dropdown. It will disappear.
Last edited 8 years ago by BenjaminPaap (previous) (diff)

comment:2 Changed 8 years ago by Ralph.Terry

We have also experienced this problem. in an XP environment we have replicated only where a month or year dropdown is open and one clicks on the other. In a Windows 7 envioronment it occurs immediately on opening the datepicker.

Does anyone know whether there is a fix for this yet? Thanks

comment:3 Changed 7 years ago by Scott González

Milestone: 1.9.01.11.0

comment:4 Changed 7 years ago by mikesherov

Owner: set to paddyboyd
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! I can no longer reproduce the issue using the latest jQuery and jQuery UI. http://jsfiddle.net/WbyH8/

If you can still reproduce it, please respond so I can investigate it further. Thanks!

comment:5 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.