Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7311 closed bug (worksforme)

DatePicker ui-datepicker-div shows at bottom of page

Reported by: cousinjoe2005 Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.12
Keywords: Cc:
Blocked by: Blocking:

Description

I've recently noticed a problem with all pages on my site where I'm using the jQuery UI DatePicker control. There is a div with an id of "ui-datepicker-div" which is visible at the bottom left corner of the page on page load. This div disappears once a DatePicker element has been displayed (even if it is closed later). I've attached a screenshot of what the page looks like and here's a pastebin with the full page source.

http://pastebin.com/dKxtgBMV

http://www.flickr.com/photos/30888552@N04/5684113902/

Change History (5)

comment:1 Changed 9 years ago by Scott González

Resolution: worksforme
Status: newclosed

Please provide a reduced test case (strip out the hundreds of lines of scripts and content) and make sure you're using the latest CSS and JS files.

comment:2 Changed 9 years ago by cousinjoe2005

Here's a different pastebin with only relevant code (I kept the original intact in case it is still useful):

http://pastebin.com/5KuBFRGM

I have confirmed we are using the latest jQuery and jQuery UI

Last edited 9 years ago by cousinjoe2005 (previous) (diff)

comment:3 Changed 9 years ago by Scott González

Please host your file somewhere. It doesn't help to just see your code when our demos work.

comment:5 Changed 9 years ago by Scott González

That's not a 1.8.12 theme. Please use a valid theme from the download builder.

Note: See TracTickets for help on using tickets.