Opened 8 years ago

Closed 8 years ago

#7313 closed bug (worksforme)

Ctrl+End move focus to datepicker field

Reported by: alon@… Owned by: alon@…
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.11
Keywords: Cc:
Blocked by: Blocking:

Description

After selecting a date with datepicker, the focus move to the document, allowing the user to click again on the field and reopen the datepicker dialog. When the user click Ctrl+End (delete the current date form the field), the dialog close but the focus is on the field - The focus need to move to the document so the user can open the dialog again without the need to moving the focus away from the datepicker field.

Change History (3)

comment:1 Changed 8 years ago by Scott González

Owner: set to alon@…
Status: newpending

I don't understand the steps you're using, if the datepicker is open and the text field has focus, the datepicker should not close just from using the keyboard (unless you press escape).

comment:2 Changed 8 years ago by alon@…

Status: pendingnew

I hope this will help - http://jqueryui.com/demos/datepicker/

  1. Click on the date field to open the datepicker, and select a random date
  2. Click again on the date field, and the datepicker dialog will open again - That's good!

Bug:

  1. Open the datepicker again, and this time click Ctrl+End to clear the date from the field
  2. Click again on the date field - the datepicker dialog is not opening because the focus is already in the date field

comment:3 Changed 8 years ago by Scott González

Resolution: worksforme
Status: newclosed

Ok, so I see in the documentation that ctrl+end closing the datepicker is expected behavior. I'm closing this since using the keyboard should not change focus unless you explicitly move to another field. I don't see a reason that ctrl+end should have different behavior from escape, ctrl+a, delete.

Note: See TracTickets for help on using tickets.