Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7331 closed bug (worksforme)

Suggestions scrolling minor fix

Reported by: michal.pokrywka Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.12
Keywords: Cc:
Blocked by: Blocking:

Description

Autocomplete with scrollable results has visual imperfection when using keyboard.

To reproduce: set menu (ul) max height to integer multiply of item (li a) height, add border to menu, scroll suggestions using keyboard up and down.

Test: http://jsfiddle.net/Q5VmF/2/

Proposed fix included in jsfiddle

Change History (5)

comment:1 Changed 9 years ago by Scott González

Status: newopen

Thanks, would you mind sending a pull request with this patch? You would need to apply the patch to jquery.ui.menu.js in master.

comment:2 in reply to:  1 ; Changed 9 years ago by michal.pokrywka

Looks like it is fixed in master,
I modifed jsfiddle http://jsfiddle.net/Q5VmF/3/
to load jqueryui from github and "glitch" is no longer present.

Consider this report as invalid.

comment:3 Changed 9 years ago by rdworth

Resolution: worksforme
Status: openclosed

comment:4 in reply to:  2 ; Changed 9 years ago by wuzz

Replying to michal.pokrywka:

Looks like it is fixed in master,
I modifed jsfiddle http://jsfiddle.net/Q5VmF/3/
to load jqueryui from github and "glitch" is no longer present.

Consider this report as invalid.

try this with jq1.6 or 1.6.1 - scrolling to active item does not work anymore. works fine in 1.5.

comment:5 in reply to:  4 Changed 9 years ago by Scott González

Replying to wuzz:

try this with jq1.6 or 1.6.1 - scrolling to active item does not work anymore. works fine in 1.5.

That's a completely unrelated problem. Please file a new ticket. Thanks.

Note: See TracTickets for help on using tickets.