Opened 9 years ago

Closed 9 years ago

#7428 closed bug (notabug)

Regression in draggable behavior in Chrome from 1.8.12 to 1.8.13

Reported by: quintin3265 Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.core Version: 1.8.13
Keywords: Cc:
Blocked by: Blocking:

Description

I believe that a regression occurred between versions 1.8.12 and 1.8.13 in Google Chrome. Unfortunately, I have been unable to determine the cause of the problem despite hours of debugging, other than that something happened in the Jquery UI, and can't devote any more time to it. I thought I would point it out here in case someone wants to attempt to look into it at some point. If the test case is too complex, I do not have time to assist in reducing it.

If you create an account at http://www.lifecentral.info/, click on "Make entries," click on the calendar to create an entry, and attempt to drag the entry around the grid using Google Chrome, the draggables do not work, or work once and then stop working. The resizable property seems to be lost as well. This production site was upgraded to version 1.8.13.

But when you go to http://svillage.mine.nu/ and do the same procedure using this development site that I downgraded to version 1.8.12, you'll notice that the draggables function correctly in all versions of Chrome and so do the resizables. You can drag the events around the calendar as many times as you like and there are no issues. This application has worked fine for six months with all versions of the Jquery UI until version 1.8.13 was released.

All browsers other than Chrome work perfectly in both cases.

There are no other changes in the application, so the behavior is caused solely by a change in the Jquery UI. The issue is always reproducible using Chrome 11 and 12. If someone believes this is an issue that warrants attention, I can grant deeper access to the development system for debugging; if the ticket is rejected, I'll simply downgrade to version 1.8.12 and give up.

Change History (2)

comment:1 Changed 9 years ago by quintin3265

This ticket should be closed. It turns out that downgrading did not fully resolve the solution in all cases, so the bug is not in the Jquery UI.

comment:2 Changed 9 years ago by Scott González

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.