Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7429 closed bug (duplicate)

ui.button widget form reset issue

Reported by: xStream Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.button Version: 1.8.13
Keywords: Cc:
Blocked by: Blocking:

Description

In jQueryUI 1.8.13 I got next problem:

I have some forms, and have some disabled buttons out of them (made by ui.button widget). When I press reset button on any form ANY 'ui.button'-ed element on the page loose their 'disable' state.

I found that problem is next line:

$( ":ui-button", event.target.form ).each(function() {

in formResetHandler function in the widget.

event.target.form is always undefined, so selector get all elements from whole page.

I replaced it with just event.target and all works correct now (checked in Firefox 4+, Opera 10+, IE 8-9, Safari 5, Chrome 9)

Change History (2)

comment:1 Changed 9 years ago by rdworth

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by rdworth

Duplicate of #7261.

Note: See TracTickets for help on using tickets.