Opened 8 years ago

Closed 7 years ago

#7443 closed bug (invalid)

Issue using sortable on an element with a border (FF only)

Reported by: jranck Owned by: jranck
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.8.13
Keywords: Cc:
Blocked by: Blocking:

Description

There seems to be an issue while using sortable() on a set of elements that have a border in Firefox 4.0.1. The elements will be sortable and allow for drag and drop the issue is the corresponding "space" or placeholder area that is supposed to show up as you drag an element down the sortable list. This space/placeholder is supposed to be the same height as the element being dragged but in FF this height doesn't seem to be calculating correctly. Because of this it makes dragging larger elements troublesome. The odd piece is that it works fine without the border or if the border is added to the inline style tag. It also works in every other browser I've tested (IE 7/8/9, Chrome, and Safari) but not in FF 4, I haven't tested yet in FF 3. Any ideas?

Change History (5)

comment:1 Changed 8 years ago by jranck

I should add that it only happens when the border is added through CSS. As I mentioned above it actually works fine when there isn't a border or the border is added through an inline style tag.

comment:2 Changed 8 years ago by jpayne82

I'm seeing the exact same behavior in Safari 5.0.5 on Mac OS X 10.6.8.

comment:3 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:4 Changed 7 years ago by petersendidit

Owner: set to jranck
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the git version of both jQuery UI and jQuery to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/ZgAqH/Open the link and click to "Fork" (in the top menu) to get started.

comment:5 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.