Opened 9 years ago

Closed 9 years ago

#7444 closed enhancement (wontfix)

Ability to get handle position in slide() event

Reported by: cowwoc Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.slider Version: 1.8.13
Keywords: Cc:
Blocked by: Blocking:

Description

JQuery UI 1.8.13 updates the handle position after returning from the slide() callback function. This makes it impossible to implement tooltips that float directly above a horizontal slider because the tooltip will always display at the previous handle position.

Expected behavior: fire a new event after a slide has been accepted or pass the expected slider position into the slide() function.

Change History (1)

comment:1 Changed 9 years ago by Scott González

Resolution: wontfix
Status: newclosed

Just use setTimeout( fn, 1 ). You know it will be correct immediately after the event.

Note: See TracTickets for help on using tickets.