Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7450 closed bug (duplicate)

jQuery UI is leaking on Internet Explorer 6 (datepicker is leaking)

Reported by: E. Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.13
Keywords: Cc:
Blocked by: Blocking:

Description

When loading jQuery UI 1.8.13 on Internet Explorer 6, it uses 2MB of Virtual Memory every time a page is loaded (there's no need to actually USE jQuery UI, just load the .js in an HTML page and 2MB are wasted on every load).

Note that this issue does not affect Internet Explorer 8 or Internet Explorer 9 (nor Firefox). Note that this issue does not occur when using jQuery 1.4.2 and jQuery UI 1.8.2 (not sure about versions between 1.8.2 and 1.8.13).

Further investigations showed that the "datepicker" widget is actually leaking (a reduced version of jQuery with this component does not leak).

A very simple test case in HTML would be:

<html>

<head>

<title>Loading jQuery-UI creates a ressource leak in IE6</title> <script language="javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.1/jquery.min.js"></script> <script language="javascript" src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.13/jquery-ui.min.js"></script>

</head> <body>

<h3>Loading jQuery-UI creates a ressource leak in IE6</h3> <A href="javascript:window.location.reload()">Click to Reload (and leak around 2MB on IE6)</A>

</body>

</html>

Just load and reload this HTML page a couple of times and IE will grow on used memory... until it breaks out with "out of memory errors"...

Change History (2)

comment:1 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by Scott González

Duplicate of #4566.

Note: See TracTickets for help on using tickets.