Opened 9 years ago

Closed 9 years ago

#7468 closed bug (notabug)

Wrappers used by UI effects are created in an invalid context

Reported by: mstekel Owned by: mstekel
Priority: minor Milestone: 1.9.0
Component: ui.effects.core Version: 1.8.13
Keywords: Cc:
Blocked by: Blocking:

Description

Function name: createWrapper Line: 4353 (not minimized) Current code: wrapper = $('<div></div>') Correct code: wrapper = $('<div></div>', element[0].ownerDocument) Reason: You cannot wrap elements living in one "ownerDocument" by elements created in another ownerDocument. Doing it on IE9 throws the WRONG_DOCUMENT_ERR and Microsoft guys are right this time.

Change History (4)

comment:1 Changed 9 years ago by bmsterling

@mstekel, Can not reproduce with 1.8.14, can you test in the version and if able to reproduce can you provide some test code?

comment:2 Changed 9 years ago by Scott González

Component: ui.coreeffects.core

comment:3 Changed 9 years ago by Corey Frang

Owner: set to mstekel
Status: newpending

I assume there is some sort of IFRAME trickery going on here? Can you reproduce this on jsfiddle and send us a link?

comment:4 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.