Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#7482 closed bug (notabug)

KeyError: 'captcha_redirect'

Reported by: dsarosi Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.core Version: 1.8.13
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'6e383dfaa3dfdb12ea89deeb',
 'recaptcha_challenge_field': u'03AHJ_VuvfEfY3MD6KxcwLKnmQNOGg89c45Za7c2WwC8tlSqrsX23AipXYdjt76t7gB4tWze2WEt0U9z_K7kbSStXexDl6k2UeAgZ1lKafFG9AWEUwbcGCVKfjy_YDwcw9z_MgOQeB6298k8HTyvxm-zxwvYn5DSDQ_g',
 'recaptcha_response_field': u'five tssionab'}

User agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.17) Gecko/20110422 Ubuntu/10.04 (lucid) Firefox/3.6.17

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/TracSpamFilter-0.4.1dev_r10170-py2.6.egg/tracspamfilter/captcha/api.py", line 119, in pre_process_request
    del req.session['captcha_redirect']
KeyError: 'captcha_redirect'

Change History (2)

comment:1 Changed 9 years ago by Scott González

Resolution: invalid
Status: newclosed

comment:2 Changed 7 years ago by Scott González

#9249 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.