Changes between Initial Version and Version 1 of Ticket #7489


Ignore:
Timestamp:
Jun 18, 2011, 8:53:31 PM (11 years ago)
Author:
rdworth
Comment:

This is as designed. The autocomplete widget depends on ui.menu via $.fn.menu. That way you can provide your own $.fn.menu and it will depend on it instead of the one that lives at $.ui.menu. If you want your own menu that doesn't fill that role, give it a different alias in the $.fn. namespace with $.widget.bridge and then use bridge to restore the $.fn.menu -> $.ui.menu alias:

$.widget.bridge( "jqnMenu", $.jqn.menu );
$.widget.bridge( "menu", $.ui.menu );

This assumes you load autocomplete (which includes ui.menu) first, then jqn.menu. If you load jqn.menu before autocomplete then only the first line above should be needed. If you have additional questions about this, please ask on the forum http://forum.jquery.com/using-jquery-ui

For more on the widget bridge, see http://www.erichynds.com/jquery/using-jquery-ui-widget-factory-bridge/

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #7489

    • Property Status changed from new to closed
    • Property Resolution changed from to invalid
  • Ticket #7489 – Description

    initial v1  
    1 the issue is when a menu widget is created in a different namespace ie: 'jqn.menu' the menu property of the autocomplete control no longer has access to the methods defined in 'ui.menu' the menu object is no referencing 'jqn.menu'.
     1the issue is when a menu widget is created in a different namespace ie: 'jqn.menu' the menu property of the autocomplete control no longer has access to the methods defined in 'ui.menu' the menu object is now referencing 'jqn.menu'.
    22
    33this issue was observed in version 1.8.1. based on the look I have taken at version 1.8.13, I believe the issue is still present there as well.