Opened 8 years ago

Closed 7 years ago

#7519 closed bug (invalid)

mouseup pb with IE9

Reported by: PIR2 Owned by: PIR2
Priority: minor Milestone: 2.0.0
Component: ui.resizable Version: 1.8.14
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

I've encountered a bug with IE 9 and resizing using the layout plugin (http://layout.jquery-dev.net/index.cfm).

(possibility that resizable, draggable, mouse widgets are implied)

I don't know if it's an IE 9 bug or Jquery UI widget bug.

The pb : see above for instructions to reproduce the bug at http://jqueryui.com/demos/sortable/#connect-lists

This is also reported by another user at : http://forum.jquery.com/topic/missed-mouseup-problem-in-sortable-list-ie-9 (and you can reproduce it using ui-demo : http://jqueryui.com/demos/sortable/#connect-lists).

  • drag and drop between the connected lists
  • after the last drop, move your mouse to the right and hover over the links in the Examples sidebar.
  • expected result: hover causes cursor to change, actual result: cursor doesn't change
  • now click somewhere on the screen
  • hover over the links again and the cursor will change as expected.

We've noticed also : After the resize and/or drag, without click, try closing the browser, you have to take two clicks to close IE 9. After the resize, move the cursor to a text or link field and you will see that the cursor image is not altered.

We've also discussed this here : http://groups.google.com/group/jquery-ui-layout/browse_thread/thread/bf9b65344534cd3a

Change History (4)

comment:1 Changed 8 years ago by PIR2

I've created a test case in jsfiddle from the ui-demo source code (sortable#connect-lists)

see : http://jsfiddle.net/6pkSB/

step to reproduce, with IE 9.0 :

case 1 :

  • drag and drop between the connected lists
  • after the last drop, move your mouse to top-left and hover over the links "documentation" or "our blog"... (or on the resizers)
  • expected result: hover causes cursor to change, actual result: cursor doesn't change
  • now click somewhere on the screen
  • hover over the links again and the cursor will change as expected.

case 2 :

  • reproduce step 1
  • After the drag, without click, try closing the browser, you have to take two clicks to close IE 9

comment:2 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 7 years ago by tj.vantoll

Owner: set to PIR2
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project. I can no longer create this problem on the demo (http://jqueryui.com/sortable/#connect-lists) or the fiddle provided (http://jsfiddle.net/6pkSB/).

Can you provide any additional information to help us recreate this?

comment:4 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.