Opened 8 years ago

Closed 7 years ago

#7525 closed bug (notabug)

Accordion: Quick Flicker in Firefox 3.6.18

Reported by: pmuessig Owned by: pmuessig
Priority: minor Milestone: 1.9.0
Component: ui.accordion Version: 1.8.14
Keywords: Cc:
Blocked by: Blocking:

Description

Scrollable multiselect inputs with a selected value inside of an accordion panel cause a quick but noticeable flicker when you change between accordion panels. This seems to only happen when a selected value in the input is scrolled down lower then the initial viewable area of the input.

It seems that other browsers don't scroll their multiselect inputs so this flicker doesn't happen to them (tested in chrome 13.0.782.32 beta-m and IE8, no flicker).

setup:

  • jquery 1.6.1
  • jquery ui 1.8.14
  • windows xp sp3
  • firefox 3.6.18

Link to reproduce: http://jsfiddle.net/tWBmN/2/

Steps to reproduce bug:

  • Scroll to the bottom of the input box in the first section and select the last item.
  • Toggle between the sections several times to see an initial flicker before the animation between the panels.

Notice if you select a value within the first 6ish items, this flicker won't occur. However, if you select the first item in the first accordion panel, then scroll the input down so you don't see it selected, then switch to second accordion panel it will occasionally cause flicker (not every time it seems).

Change History (2)

comment:1 Changed 7 years ago by Scott González

Owner: set to pmuessig
Status: newpending

I can't reproduce this. Do you still see this problem? If so, do you see it in newer versions of Firefox?

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.