Opened 8 years ago

Closed 6 years ago

#7529 closed bug (invalid)

Button() checkbox problem with blanks space between words) and / in a string

Reported by: jorg76440 Owned by: jorg76440
Priority: minor Milestone: 1.11.0
Component: ui.button Version: 1.8.14
Keywords: Cc:
Blocked by: Blocking:

Description

As soon as you use for the labels of the checkbox button() function two words seperated by a blank space, the button() doesn't work any more and creates persistant problems in the following calls to the button() function as checkboxes. You get the same problem if you put a / in a string

Change History (9)

comment:1 Changed 8 years ago by epascarello

Could you add a code example showing this error? Your bug description is hard to follow.

comment:2 Changed 8 years ago by Scott González

Status: newopen

The example markup would be as simple as:

<label for="foo">this has spaces/and slashes</label><input type="checkbox" name="foo">

You can modify the checkbox button demo to have slashes in the labels and see the problem.

comment:3 Changed 8 years ago by epascarello

I just tested it with the 1.9 development version pulled from github and it seems to be working fine.

Added

<label for="foo">this has spaces/and slashes</label><input type="checkbox" name="foo" id="foo">

Initialized it with

$( "#foo" ).button();

Tested the follow js code against it

$( "#foo" ).button("disable");
$( "#foo" ).button("enable");
alert($( "#foo" ).attr("checked"));
$( "#foo" ).attr("checked", true);
$( "#foo" ).button("refresh");

comment:4 Changed 6 years ago by Scott González

Milestone: 1.9.01.11.0

comment:5 Changed 6 years ago by dalekocian

Owner: set to dalekocian
Status: openassigned

comment:6 Changed 6 years ago by mikesherov

Owner: dalekocian deleted
Status: assignedopen

Looks like this can enter back into the general pool.

comment:7 Changed 6 years ago by djQuery

Attempt at reproducing http://jsbin.com/onupip/2/edit

I can't reproduce this issue, plus submit a demo of this issue please.

comment:8 Changed 6 years ago by Scott González

Owner: set to jorg76440
Status: openpending

I feel like I was able to reproduce this before, but I can't any more, even with 1.8.14.

comment:9 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.