Opened 8 years ago

Closed 6 years ago

#7569 closed feature (invalid)

Regarding jquery bounce effect

Reported by: sunny85indore Owned by: sunny85indore
Priority: minor Milestone: 1.10.0
Component: ui.effects.* (individual effect) Version: 1.8.14
Keywords: Cc:
Blocked by: Blocking:

Description

Regarding jquery bounce effect

I am using bounce effect for times: 1, and time 100 (1 second), its working fine on all browsers.

I use this effect to append div dynamically in a big Div. e.g. In Main Div, i will append div 1, div 2, div 3 at top as they comes. Now what happens is that if more than one div comes at top at same time, this effect collides and performs weirdly. It creates unnecessary gaps in between divs and also overlaps divs. Please help me out jquery team.

Thanks in Advance!

Change History (14)

comment:1 Changed 8 years ago by Corey Frang

Milestone: 1.9TBD
Owner: set to sunny85indore
Status: newpending

Can you please post an example of the problem on jsFiddle or jsbin? We need more information to track down this bug. This could be one of those situations where you should be posting to the forums instead of the bug tracker as well.

Last edited 8 years ago by Corey Frang (previous) (diff)

comment:2 Changed 8 years ago by sunny85indore

Status: pendingnew

Look Sir,

There is a main Div and what we do is that we append the new div within that main div like <Div main>

<Div3></Div> <Div2></Div> <Div1></Div>

</Div>

What happens is that we append every new chat message in that Main div, like if next chat message will come, it will be Div 4 (appended above this old divs in MAIN div). Now problem is if more than one div gets bounce effect at same time, Div overlap each other and also unwanted gap between Divs (div1,div) gets created. I hope i ve helped you to understand....

comment:3 Changed 8 years ago by Corey Frang

Status: newpending

If you cannot provide a testcase illustrating this issue, we cannot investigate it any further as a bug. If you are able to create a test case, please link to it here. Please use jsFiddle or jsbin to provide test cases

comment:4 Changed 8 years ago by sunny85indore

Status: pendingnew

allright

please find this url: http://livecommonnew.test.gate6.com/ver2/client.php

this is set up for you to test this out, when we continuously enter messages in very less time interval like 3-4 messages in 1-2 seconds, gap is created between divs and they overlap

please see it

Thanks allot!

comment:5 Changed 8 years ago by Corey Frang

Status: newpending

It sounds to me like you have a really good idea what it might take to make a "minimal" reproduction of this issue on a jsFiddle or jsbin. I'm not interested in seeing a ton of HTML/JS with a login/out AJAX Chat system etc... I want to see the smallest number of step to see the bug as possible, reproduced very easily for my eyes to view. Please use jsFiddle or jsbin...

comment:6 Changed 8 years ago by sunny85indore

Status: pendingnew

It wont be possible for me to create that scenario, its a big deal, my question is simple respected sir, if bounce effect is hit for same position (div) getting appended, than how they can be handled so that they dont cross each other and work individually, currently when they two div get the same bounce effect to get append in a div, they create problems.... Thanks mate!

comment:7 Changed 8 years ago by Corey Frang

Status: newpending

So, this is my attempt at taking your description and turning it into a demo of a problem: http://jsfiddle.net/Q5GT6/

I'm not seeing the problem... You need to get a reproducible test case for us to work from.

comment:8 Changed 8 years ago by Scott González

perhaps adding margin? http://jsfiddle.net/Q5GT6/1/

comment:9 Changed 8 years ago by sunny85indore

Status: pendingnew

thanks for making the initial mockup now its set up properly pls check now.... Thanks!

comment:10 Changed 8 years ago by Corey Frang

If you made some changes in that code sunny, you never saved it... Press the "Update" button on the top, and then copy the URL into this form please....

comment:11 Changed 7 years ago by Scott González

Type: enhancementfeature

comment:12 Changed 6 years ago by Scott González

Milestone: TBD1.10.0

comment:13 Changed 6 years ago by mikesherov

Status: newpending

comment:14 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.