Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7598 closed bug (duplicate)

Add the ability to specify options for the buttons.

Reported by: David.Sullivan Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.14
Keywords: Cc:
Blocked by: Blocking:

Description

It would be nice of .dialog({buttons: {}) accepted a buttonOptions for each of the buttons. Example

$('#myDialog').dialog({
        buttons: [{
            text: 'Test',
            butttonOptions: { //Any valid .button options should be able to be passed here.
                icons: {
                    primary: 'ui-icon-disk'
                }
            }}]
    });

I see where the change to .dialog need to be done and will be submitting a pull request.

Change History (3)

comment:2 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:3 Changed 8 years ago by Scott González

Duplicate of #6830.

Note: See TracTickets for help on using tickets.