Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7608 closed bug (duplicate)

Modal dialog blocks all text inputs inside it (in special case)

Reported by: Rostyslav Bryzgunov Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.14
Keywords: Cc:
Blocked by: Blocking:

Description

I create modal dialog with form inside it (with some text input). And I just can't enter the text inside the textbox. Dialog blocks keyboard input.

Here is my simplified example:

<div id="modal-dialog">
    <label for="my-text">TRY to input text...</label>
    <textarea id="my-text" style="position:relative; z-index:1"></textarea>
</div>
<script type="text/javascript">
    var dialog = $('#modal-dialog').dialog({ modal: true });
</script>

Note: I mentioned about "position:relative; z-index:1" because it works fine without it. But I can't remove it because of design.

Note: not modal dialog works fine too.

I'm using jQuery 1.6.2 + jQuery UI 1.8.14

Change History (2)

comment:1 Changed 8 years ago by Scott González

Component: ui.coreui.dialog
Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by Scott González

Duplicate of #5466.

Note: See TracTickets for help on using tickets.