Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7611 closed bug (duplicate)

Percentage heights conflict with effect wrapper

Reported by: MetalArend Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.effects.core Version: 1.8.14
Keywords: Cc:
Blocked by: Blocking:

Description

When an effect wrapper wraps around an element with a percentage height or width, this height or width recalculates. Instead it should keep the calculated height/width that the element had before the animation.

jQuery: 1.6.2 jQuery UI: 1.8.14 browser: FFX 5.0

Code example:

<!doctype html> <html> <head>

<title>bug</title> <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script> <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.14/jquery-ui.min.js"></script> <style>

a { color: inherit; } .bug_box { margin: 5px; float: left; border: 5px double #eeeeff; } .bug_playground { height: 300px; width: 300px; background: #aaaacc; } .bug_problem { height: 150px; width: 150px; background: #ff0000; }

</style>

</head> <body>

<div class="bug_box">

<div class="bug_playground">

<div id="bug01" style="height: 50%; width: 50%;" class="bug_problem">BUG 01</div>

</div> <a href="#" onclick="$('#bug01').toggle('slide', 'slow');">Show / Hide</a>

</div>

</body> </html>

Change History (4)

comment:2 Changed 8 years ago by Corey Frang

Resolution: duplicate
Status: newclosed

This should be fixed in master. http://jsfiddle.net/ttREE/1/ is your test case using the version of effects in git.

comment:3 Changed 8 years ago by Corey Frang

Duplicate of #5245.

comment:4 in reply to:  3 Changed 8 years ago by MetalArend

Replying to gnarf:

Duplicate of #5245.

Check, it is. Sorry I didn't find that before posting it again!

Note: See TracTickets for help on using tickets.