Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7637 closed bug (duplicate)

Droppable always picks first droppable

Reported by: kevinpeno Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.droppable Version: 1.8.15
Keywords: Cc:
Blocked by: Blocking:

Description

When determining if the droppable meets criteria, the system doesn't check: z-index, position, or if the droppable is even in view (such as in a case where a div with droppables flows under a side bar, that is position absolute; that contains droppables). In all cases, the first one meeting tolerance (in order of appearance in the DOM) wins.

A super simple example: http://jsfiddle.net/TK5gu/

I can provide a more "real" test case that shows a real world need for this fix in necessary. This is kind of a blocker for me, so I'll need to find a workaround. I'll post back if I can find something.

Change History (2)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by Scott González

Duplicate of #3452.

Note: See TracTickets for help on using tickets.