Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7677 closed bug (worksforme)

Radio Buttonsets do not update checked attribute onclick in IE7

Reported by: jrummell Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.button Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

  1. The version(s) of jQuery affected

jQuery UI 1.8.16 and possibly earlier versions

  1. The browser (or browsers) that you are able to reproduce the bug in, including version numbers

Internet Explorer 7

  1. The operating system (or operating systems) you experienced the bug on.

Windows 7

  1. Step-by-step instructions on how to reproduce the issue, including any required system configuration changes

Create a page with multiple radio inputs that have the same name, then create a jQuery UI buttonset on their container. See http://jsfiddle.net/jrummell/ELjVW/embedded/result/ for an example.

  1. A description of what you expect to happen, and what actually happens

I expect that when clicking one of the radio buttons the checked attribute would be set, but it is not.

Change History (2)

comment:1 Changed 8 years ago by rdworth

Resolution: worksforme
Status: newclosed

Not sure how you were testing the checked value, that should be included in your steps to reproduce. In any case, I was not able to reproduce in IE7 on Windows XP when adding a button to alert the checked value: http://jsbin.com/alivos

comment:2 Changed 8 years ago by jrummell

Thanks for the quick response. I may have oversimplified the example. I'll do some more testing and I'll update if I can reproduce the issue.

Note: See TracTickets for help on using tickets.