Opened 8 years ago

Closed 8 years ago

#7689 closed bug (notabug)

Wrong height of parent container when using

Reported by: hilbert00 Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.position Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

I have found this strange behaviour when using ui.position. I have a widget designed in a column wise manner and I was thinking to use the position utility to position the left and right cols and their position.

The problem is that after the positioning of the right col to the right, the height of the container box is much heigher than needed as it would contain the left and right divs one after the other.

This is the link to the jsFiddle test case: http://jsfiddle.net/hilbert00/sAbxS/

The problem is occurring in both FF6 and Chrome 13.0.782.218 OS: Linux

Change History (1)

comment:1 Changed 8 years ago by rdworth

Resolution: invalid
Status: newclosed

No bug in the position utility here, as demonstrated by removing it from your test case http://jsfiddle.net/JKrfa/

For further discussion on the layout you're trying to achieve and why it wasn't as straightforward (using position) as you presumed, see https://forum.jquery.com/topic/wrong-height-of-parent-container-when-using-position-utility

Note: See TracTickets for help on using tickets.