Opened 8 years ago

Closed 7 years ago

#7737 closed bug (fixed)

change event for form elements not firing inside dialog when closed by "X"

Reported by: colcode Owned by:
Priority: minor Milestone: 1.9.1
Component: ui.dialog Version: 1.8.16
Keywords: Cc:
Blocked by: #7735 Blocking:

Description

A form element (textbox, textarea) usually triggers onchange event when the element leaves focus (onblur) and the contents of the element is changed. In Firefox (tested 6.0.2) the onchange event is NOT firing when dialog is closed by clicking "X".

More precisely:

  • open dialog with a textbox or textarea
  • type something
  • click "X" to close

I'm pretty sure it worked in earlier versions of FF (3.0 or older). IE9 and Safari seem to work ok.

Testcase: http://www.colcode.com/bug/jquery-dialog-onchange-not-firing.html

Change History (4)

comment:1 Changed 8 years ago by Scott González

Status: newopen

This is caused by .disableSelection() canceling the mousedown inside the titlebar. See #7735 for related ticket.

comment:2 Changed 8 years ago by Scott González

Blocked by: 7735 added

comment:3 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:4 Changed 7 years ago by Scott González

Milestone: 1.10.01.9.1
Resolution: fixed
Status: openclosed
Note: See TracTickets for help on using tickets.