Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7748 closed bug (duplicate)

ui slider not working in Internet Explorer 9 [IE9]

Reported by: yashraj Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.slider Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

hi,

i am using UISlider in my website but i'm facing problem with IE9. slider works perfect in all browsers(chrome,firefox,safari,IE7,IE8) but when i show website in IE9, i am not able to move select cursor of my slider.

Can anyone Help me on this...?

thank you

Change History (8)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

1.7 is legacy, you should really use a supported version of jQuery UI.

comment:2 Changed 9 years ago by Scott González

Duplicate of #5370.

comment:3 Changed 9 years ago by yashraj

thank you scott.gonzalez for your reply, i used vesion 1.8 but still facing a problem.

what i get to know is there is some problem with IE9 in following code in _mouseMove function

_mouseMove: function (j) {

if (c.browser.msie && !j.button) {

return this._mouseUp(j)

}

if (this._mouseStarted) {

this._mouseDrag(j); return j.preventDefault()

}

if (this._mouseDistanceMet(j) && this._mouseDelayMet(j)) {

this._mouseStarted = (this._mouseStart(this._mouseDownEvent, j) !== false); (this._mouseStarted ? this._mouseDrag(j) : this._mouseUp(j))

} return !this._mouseStarted

},

in this code i came to know that in all browser except IE9 value of "this._mouseStarted" is true so _mouseDrag is called and when i release my mouse it'll go to function "_mouseUp" which is just next to function "_mouseMove". but in IE9 value of "c.browser.msie" is true and so mouseUp is returned and is not able to reach to _mouseDrag(which is in next if case). so i've return below code but still facing a problem cause in my code i am having a function call to mouseDrag but never reach to "_mouseUp". see below code

_mouseMove: function (j) {

if (c.browser.msie && !j.button && document.documentMode < 9) {

return this._mouseUp(j)

}

if (this._mouseStarted) { alert("drag");

this._mouseDrag(j); return j.preventDefault()

}

if (this._mouseDistanceMet(j) && this._mouseDelayMet(j)) {

this._mouseStarted = (this._mouseStart(this._mouseDownEvent, j) !== false); (this._mouseStarted ? this._mouseDrag(j) : this._mouseUp(j))

} return !this._mouseStarted

},

in this code i always have an alert of "drag" and not able to reach to _mouseUp. can you help me on this?? how can i solve this slider problem of IE9?

comment:4 Changed 9 years ago by Scott González

Did you use a version >= 1.8.6? This definitely works for me and everyone else.

comment:5 Changed 9 years ago by yashraj

i used "jquery-ui-1.8.6.custom.min.js" and i also tried "jquery-ui-1.8.16.custom.min.js" non of these is working for me...

comment:6 Changed 9 years ago by Scott González

comment:7 Changed 9 years ago by yashraj

http[:]www.finance.samif.com/Koelkast this is my site url.. this looks fine and also slider is working in all browsers except IE9. check this in IE9. slider will be in left column. (don't look at design in IE9 :-) it's bad now ).

thank you so much for support scott.gonzalez

I look forward for your reply.

Thanks

comment:8 Changed 9 years ago by Scott González

1) You're still using 1.7.1 on your site.
2) We don't provide support for full sites, only reduced test cases.
3) You never answered my question of whether the demo works for you.

At this point, I will no longer respond to any comments on this ticket. Please use the forums if you need more help.

Last edited 9 years ago by Scott González (previous) (diff)
Note: See TracTickets for help on using tickets.