Opened 8 years ago

Closed 8 years ago

#7780 closed bug (notabug)

jQuery latest stable + jQuery UI latest stable propAttr method doesn't exist

Reported by: sc0ttkclark Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

Running the latest stable of jQuery and jQuery UI, I began seeing issues with jQuery UI's autocomplete component. Specifically, it's use of propAttr. I was getting errors that the method did not exist. After digging around, it appears that replacing propAttr with attr actually fixes the issue.

I've never contributed to jQuery or jQuery UI, so forgive me if I'm overlooking something obvious here. I looked up the issue and saw another ticket closed as invalid, which was this one: http://bugs.jqueryui.com/ticket/7680

I believe propAttr is also used on other components as well, at first glance I saw that the slider component was also effected.

Change History (2)

comment:1 Changed 8 years ago by sc0ttkclark

Actually you may be able to ignore this ticket, as it appears that the version of jQuery UI we're using is a couple minor versions below 1.8.16

comment:2 Changed 8 years ago by Scott González

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.