Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7802 closed bug (duplicate)

IE7 memory growth

Reported by: bayera Owned by: bayera
Priority: minor Milestone: 1.9.0
Component: ui.widget Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

Linking jquery UI without using any widget creates memory leaks.

Test 2 HTML pages linking each other:

test1.html: <!DOCTYPE html> <html><head> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> <title>Test</title> <link type="text/css" href="css/pepper-grinder/jquery-ui-1.8.16.custom.css" rel="stylesheet" /> <script type="text/javascript" src="js/jquery-1.6.2.min.js"></script> <script type="text/javascript" src="js/jquery-ui-1.8.16.custom.min.js"></script> </head> <body> <a href="test2.html">next</a> </body> </html>

test2.html is the same with a link to test1.html

Clicking the links will result in a growing memory in IE7. Only if I really create a widget in the page like a date picker the memory is stable.

Change History (6)

comment:1 Changed 8 years ago by Scott González

Owner: set to bayera
Status: newpending

Does this happen if your download doesn't include the datepicker?

comment:2 in reply to:  1 Changed 8 years ago by bayera

Status: pendingnew

Replying to scott.gonzalez:

Does this happen if your download doesn't include the datepicker?

This happens because I use a template for the html page and generate the content. The template always links the complete jQuery UI library (jquery-ui-1.8.16.custom.min.js) and only somethimes a page shows a datepicker.

comment:3 Changed 8 years ago by Scott González

Status: newpending

I want to know you download a version of jQuery UI that does not include the code for datepicker if you still have a memory leak. Datepicker is known to leak memory; see #4566.

Version 0, edited 8 years ago by Scott González (next)

comment:4 in reply to:  3 Changed 8 years ago by bayera

Status: pendingnew

Replying to scott.gonzalez:

I want to know if you download a version of jQuery UI that does not include the code for datepicker if you still have a memory leak. Datepicker is known to leak memory; see #4566.

No, it grows only with the datepicker.

comment:5 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:6 Changed 8 years ago by Scott González

Duplicate of #4566.

Note: See TracTickets for help on using tickets.