Opened 8 years ago

Closed 7 years ago

#7805 closed bug (wontfix)

Dialog: Height parameter ignored when the selected element is a table

Reported by: jakery Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.dialog Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

When I attempt to render a <table> as a dialog window, my height:750 parameter seems to be ignored: http://jsbin.com/anosuz/11/edit#preview

Also, here is a $("table").dialog() call where the table is shorter than the parameter, again ignoring the custom height: http://jsbin.com/ukakat/3/edit#preview

Rendering tables inside a <div> tag seems to eliminate this issue, but feels rather kludgy: http://jsbin.com/ukakat/2/edit#preview http://jsbin.com/anosuz/13/edit#preview

Also, here is my workaround where I render an empty dialog and then pull the table into the window as part of the open() callback:

http://jsbin.com/ovebod/2/edit#preview

Is this behavioral inconsistency a bug or is this by design?

Change History (2)

comment:1 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:2 Changed 7 years ago by petersendidit

Resolution: wontfix
Status: newclosed
Summary: Height parameter ignored when the selected element is a tableDialog: Height parameter ignored when the selected element is a table

Overflow: scroll on tables does not work like you want them to. This is a case where the amount of extra code to handle this case is more than its worth. It is very easy to wrap the table in a div and call the dialog on that div and that should solve all the problems that come along with calling dialog on a table.

Note: See TracTickets for help on using tickets.