Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7807 closed bug (duplicate)

Form in modal dialog submits on enter keypress if only one field present

Reported by: jcstarck Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

This is a bug. The #6967 is valid. Just make a simple test with a modal dialog with only one input text. When the dialog open just press enter. The page is submitted like a refresh page. I tested with firefox 7.01 and IE 8.

Change History (4)

comment:1 Changed 8 years ago by Corey Frang

Resolution: duplicate
Status: newclosed

Thanks for your contribution, however please do not intentionally create duplicate tickets.

comment:2 Changed 8 years ago by Corey Frang

Duplicate of #6967.

comment:3 in reply to:  2 Changed 8 years ago by jcstarck

Replying to gnarf:

Duplicate of #6967.

Ok. But why is #6967 closed? Please, take a look in:

jsFiddle (two inputs): http://jsfiddle.net/4PFWk/

jsFiddle (one input): http://jsfiddle.net/h7n2Y/

comment:4 Changed 8 years ago by rdworth

Ticket #6967 is quite clear on why it invalid. Please reference the very next comment http://bugs.jqueryui.com/ticket/6967#comment:3 that has two fiddles that show this behavior is present in browsers without even JavaScript

Note: See TracTickets for help on using tickets.