Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7808 closed bug (duplicate)

Memory leak jQuery.ui.widget

Reported by: Yoshiharu Kamata Owned by: Yoshiharu Kamata
Priority: minor Milestone: 1.9.0
Component: ui.widget Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

Memory leak jQuery.ui.widget. Memory (private bytes of IE process) increases when create and destroy of the simple widget are repeated.

jQuery core 1.6.4 jQuery.ui 1.8.16 browser IE8 OS Windows XP SP3

Memory Leak test code http://jsfiddle.net/NzJGH/3/

Workaround code http://jsfiddle.net/NzJGH/2/

Change History (7)

comment:1 Changed 10 years ago by Scott González

Owner: set to Yoshiharu Kamata
Status: newpending

That code doesn't exist in master anymore, are you still seeing a memory leak when you test against master?

comment:2 Changed 10 years ago by Yoshiharu Kamata

Status: pendingnew
Last edited 10 years ago by Yoshiharu Kamata (previous) (diff)

comment:3 in reply to:  1 Changed 10 years ago by Yoshiharu Kamata

Replying to scott.gonzalez:

That code doesn't exist in master anymore, are you still seeing a memory leak when you test against master?

I tested the master, but memory increases. Please confirm comment 2.

comment:4 in reply to:  description Changed 10 years ago by Yoshiharu Kamata

Replying to Yoshiharu Kamata:

Memory leak jQuery.ui.widget. Memory (private bytes of IE process) increases when create and destroy of the simple widget are repeated.

jQuery core 1.6.4 jQuery.ui 1.8.16 browser IE8 OS Windows XP SP3

Memory Leak test code http://jsfiddle.net/NzJGH/3/

Workaround code http://jsfiddle.net/NzJGH/2/

=> update! http://jsfiddle.net/yoshi6jp/aHHNw/1/

comment:6 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:7 Changed 10 years ago by Scott González

Duplicate of #4188.

Note: See TracTickets for help on using tickets.