Skip to main content

Search and Top Navigation

#7810 closed bug (fixed)

Opened October 25, 2011 01:00PM UTC

Closed March 01, 2012 02:22PM UTC

Consistent naming convention for .data() keys

Reported by: scottgonzalez Owned by: jzaefferer
Priority: blocker Milestone: 1.9.0
Component: [meta] Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

There's a lot of variation in naming conventions for data stored on elements. We should formalize a naming convention and use it everywhere.

Attachments (0)
Change History (4)

Changed October 25, 2011 01:01PM UTC by scottgonzalez comment:1

priority: minorblocker
status: newopen

Changed February 28, 2012 10:03PM UTC by jzaefferer comment:2

owner: → joern.zaefferer
status: openassigned

Started this in the data-naming branch.

Changed March 01, 2012 12:43PM UTC by jzaefferer comment:3 addresses a good chunk of this.

Remaining: Widget, interactions and datepicker.

Widget currently sets data based on the widget's name. Changing that needs a BC layer.

Interactions rely a lot on other interactions, accessing them via data attributes. Haven't yet looked in detail if those are problematic.

Datepicker's usage is very similar to wiget. Looks like it just sets a datepicker property, nothing else.

Changed March 01, 2012 02:22PM UTC by jzaefferer comment:4

resolution: → fixed
status: assignedclosed

We'll ignore datepicker and interactions for now, as those are being rewritten. Everything else is addressed.