Opened 6 years ago

Closed 4 years ago

#7849 closed bug (duplicate)

Slider: accessibility

Reported by: ezufelt Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.slider Version: 1.8.16
Keywords: a11y Cc:
Blocked by: Blocking:

Description

Firefox 7.0.1 JAWS 13 Slider demo 1.9pre

Problem

Slider is represented as '#' link. It is necessary to tab to the '#', disable virtual PC cursor (JAWS key + z), then use arrows to move slider, then turn virtual PC cursor back on (JAWS key + z) then to check the value.

Since some demos (color picker) don't display the value in any other way it is impossible to know if the correct value has been selected.

Solution

Provide semantics using WAI-ARIA role="slider" and associated states / properties.

See http://www.w3.org/TR/wai-aria/roles#slider

Change History (3)

comment:1 Changed 6 years ago by Scott González

Keywords: a11y added
Status: newopen

comment:2 Changed 5 years ago by Scott González

Milestone: 1.9.01.11.0

comment:3 Changed 4 years ago by Scott González

Resolution: duplicate
Status: openclosed

Duplicate of #4739.

Note: See TracTickets for help on using tickets.