Opened 8 years ago

Closed 8 years ago

#7864 closed bug (notabug)

ui-slider-range broken in jQuery 1.7

Reported by: buzzyapyear Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.slider Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

The slider range seems to be buggy as of jQuery 1.7 and jQuery UI 1.8.12.

Slider was working perfectly in jQuery 1.6.4 and jQuery UI 1.8.12;

Try clicking on various points on the slider. In my example, the blue slider range doesn't update properly to the point you've clicked on.

JS Fiddle example here:

http://jsfiddle.net/Mr2m2/1/

Am I missing something? Thanks!

Change History (3)

comment:1 Changed 8 years ago by buzzyapyear

Wanted to add that:

  1. Tested this in Chrome 15.0.874.106 and Firefox 8.
  2. I want to be clear that clicking and sliding seems to be better than simply clicking on various points on the slider. Seeing the problem much more prominently with this latter case.

comment:2 Changed 8 years ago by buzzyapyear

Further testing has revealed that the problem is the options.animate. When animate is set to false, the range problem goes away. I believe it may be erroneously using 'px' rather than '%'. So far not sure if the problem is in the slider code or the animate code.

comment:3 Changed 8 years ago by rdworth

Component: ui.coreui.slider
Resolution: invalid
Status: newclosed

This is a jQuery core issue and has already been fixed in master (will be in 1.7.1) http://bugs.jquery.com/ticket/10669

Compare 1.6.4: http://jsbin.com/asimux to 1.7.0: http://jsbin.com/ecimey to git: http://jsbin.com/azirul

Note: See TracTickets for help on using tickets.