Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7865 closed bug (duplicate)

Draggable with CSS scale transform + position absolute causes element to jump on drag begin

Reported by: paulshapiro Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.draggable Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

Basically what's going on here is that I need to use position: absolute on an element along with a css scale transform, but jQuery UI Draggable seems to use the wrong start position as if the element was not scaled. So on drag-begin it jumps.

http://jsfiddle.net/qBubN/7/

Any help would be greatly appreciated!

Change History (3)

comment:1 Changed 8 years ago by paulshapiro

As it happens I was able to fix it with this on the element being transformed:

transform-origin 0 0 -webkit-transform-origin 0 0 -moz-transform-origin 0 0

So that it sticks to the upper left

comment:2 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:3 Changed 8 years ago by Scott González

Duplicate of #6844.

Note: See TracTickets for help on using tickets.