Opened 11 years ago

Closed 10 years ago

#7884 closed bug (duplicate)

Dialog: Date picker gets behind dialog when clicked twice

Reported by: Cloetn Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.dialog Version: 1.8.16
Keywords: datepicker Cc:
Blocked by: Blocking:

Description

http://jsfiddle.net/KVBKT/

When you have a date picker placed in a dialogue and open it the first time everything works fine but when you click on the textbox AGAIN the date picker will get BEHIND the date picker.

So basically: 1th click: Date picker gets before dialogue. 2nd click: Date picker gets behind dialogue.

Change History (4)

comment:1 Changed 11 years ago by Cloetn

The jQuery timepicker plugin from 'François Gélinas' (http://fgelinas.com/code/timepicker/) had the same problem. He has already fixed it. This is the mail he send me:

'I just pushed a fix for the problem to github, grab it at https://github.com/fgelinas/timepicker I added a click event on the input and simply re-adjust zIndex on click, they probably could add this to datepicker as well.'

Last edited 11 years ago by Cloetn (previous) (diff)

comment:2 Changed 10 years ago by Scott González

Milestone: 1.9.01.10.0

comment:3 Changed 10 years ago by petersendidit

Keywords: datepicker added
Status: newopen
Summary: Date picker gets behind dialog when clicked twiceDialog: Date picker gets behind dialog when clicked twice

Was able to recreate this problem when using IE9. Wasn't able to recreate it in Chrome.

Version 0, edited 10 years ago by petersendidit (next)

comment:7 Changed 10 years ago by petersendidit

Resolution: duplicate
Status: openclosed

Duplicate of #5388.

Note: See TracTickets for help on using tickets.