Opened 7 years ago

Closed 6 years ago

#7903 closed bug (wontfix)

Slider range bug in Opera

Reported by: Mamen Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.slider Version: 1.8.16
Keywords: opera Cc:
Blocked by: Blocking:

Description

Using Opera 11.52 in Windows 7:

The current demo-page (in full screen): http://jqueryui.com/demos/slider/range.html

Sliding any of the ranges causes a white gap near the right-slider for a few steps. The content doesn't seem to be long enough. It seems that Opera ignores decimals in percentages.

Perhaps another unit than percentage would solve this bug?

Change History (6)

comment:1 Changed 7 years ago by tj.vantoll

I can confirm this bug in Opera 11.61. Per the description you can change the left CSS value of the a.ui-slider-handle node a to whole number to get the the gap to disappear. But Opera definitely seems to support decimal values for top/bottom/left/right - http://jsfiddle.net/tj_vantoll/xrVYe/, so something else must be going on.

comment:2 Changed 7 years ago by rdworth

Keywords: opera added
Status: newopen

It is not an issue with top/bottom/left/right, Opera is not supporting a float percent value for the width of the ui-slider-range element. See http://jsfiddle.net/qf6nm/

comment:4 Changed 7 years ago by Mamen

Opera 12 seems to support decimals for width.

comment:5 Changed 6 years ago by Scott González

Milestone: 1.9.01.11.0

comment:6 Changed 6 years ago by Scott González

Resolution: wontfix
Status: openclosed

Since this is fixed in newer Opera, we won't be making any changes for this.

Note: See TracTickets for help on using tickets.