Opened 8 years ago

Closed 8 years ago

#7912 closed bug (notabug)

Jquery UI Dialog resizes when dragged on Browser IE with Document Mode:Quirks

Reported by: Jansian Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

I have found a bug in jQuery dialog - it has strange behavior when dragging and resizing a dialog in IE6 or IE7 and up in Quirks Mode.

The problem is that when dragging many times then the Dialog:

•Becomes smaller;

On dragging the dialog performs some strange things. I'm doing sharepoint applications with (Browser Mode = IE8) and (Document Mode = Quirks Mode).

This bug can be even reproduced on the site itself. http://jqueryui.com/demos/dialog/

Just set the document mode to Quirks mode and start dragging the dialog a few times and you will see that the dialog resizes.

Here is a screenshot: https://lh6.googleusercontent.com/-NLUFmLxqF6I/TYew-46D7AI/AAAAAAAAAB4/RRkz8TGO05s/s1600/jQueryBUG.jpg

Change History (1)

comment:1 Changed 8 years ago by rdworth

Resolution: invalid
Status: newclosed

jQuery and jQuery UI do not support quirks mode.

Note: See TracTickets for help on using tickets.