Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7918 closed bug (duplicate)

Setting "this.floating" property on empty containers

Reported by: shareyourlocationsite Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.sortable Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

In the _create function of the sortable plugin, the floating property is set with this line;

//Let's determine if the items are being displayed horizontally
this.floating = this.items.length ? o.axis === 'x' || (/left|right/).test(this.items[0].item.css('float')) || (/inline|table-cell/).test(this.items[0].item.css('display')) : false;

But if the container is empty there will be no items. And the this.floating will be set to false.

Can you add a an option for it. Something like;

$("#container").sortable({
  floating: true
});

Change History (2)

comment:1 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by Scott González

Duplicate of #7498.

Note: See TracTickets for help on using tickets.