Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7920 closed bug (notabug)

ui.selectmenu does not support required validation

Reported by: ole Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.core Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

The jquery ui selectmenu plugin does not support required validation. See the attached test case.

Speed form A contains a selectmenu widget.

Speed form B contains a vanilla select element.

Press "Validate Speed Form B" to see expected behavior.

Press "Validate Speed Form A" and the logger will log that that form is valid.

Change History (5)

comment:1 Changed 8 years ago by Scott González

Resolution: invalid
Status: newclosed

Please use the forums or planning wiki for unreleased plugins.

comment:2 Changed 8 years ago by ole

OK - I'll reference from there. This is the pastebin, just so that everything is in one place: http://jsbin.com/ufowub/14/edit#source

comment:3 Changed 8 years ago by Felix Nagel

The Selectmenu widget is not official relased yet. Support for the UI 1.8.x branch (original by filament group, now maintained by Felix Nagel) can be found here: https://github.com/fnagel/jquery-ui/issues/

Please confirm which version you are using.

Last edited 8 years ago by Felix Nagel (previous) (diff)

comment:4 Changed 8 years ago by ole

Thanks - I'm cross referencing here: https://github.com/fnagel/jquery-ui/issues/195

I'm using the trunk from Felix's github repository for the selectmenu plugin

I'll try to attach my test case if I can. Seems like attach has been disabled in favor of jsfiddle and jsbin....

comment:5 Changed 8 years ago by Scott González

Really, please stop using this ticket.

Note: See TracTickets for help on using tickets.