Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7936 closed bug (duplicate)

Autocomplete pop-up position is incorrect if input field is no longer visible

Reported by: msk Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

Set up a tabbed interface, create an autocomplete input.

If you enter a value in the input (and you know it's complete and correct, so you don't care to wait on the autocomplete results), then click the next tab, the autocomplete results still pop-up, but with incorrect positioning.

http://jsfiddle.net/8Wbfg/2/

For this jsfiddle, just enter a value ("1") then click on the 2nd tab.

This problem can be mitigated by handling the blur event of the input and cancelling the autocomplete response callback. However, depending on browser performance (IE=slow) and server response time, there's still a small window of time where the problem can occur.

Change History (2)

comment:1 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 7 years ago by Scott González

Duplicate of #7423.

Note: See TracTickets for help on using tickets.