Opened 7 years ago

Closed 5 years ago

#7961 closed bug (duplicate)

Clicking on one UI widget prevents the default click of other UI widgets

Reported by: mlmorg Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.mouse Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

I specifically tested this with the autocomplete and draggable UI widgets. Clicking on a draggable element prevents the default click action of the autocomplete element. For example:

http://jsfiddle.net/x9RSb/

If you type "ja" in the autocomplete, the menu displays. If you then click on the draggable element, the autocomplete menu doesn't hide (the default action). If you click anywhere else on the page, the autocomplete menu will hide as predicted.

If you remove the event.preventDefault() line (line 99) of jQuery UI Mouse within the _mouseDown function, the bug is fixed; however, this commit:

https://github.com/jquery/jquery-ui/commit/a829697d0c9083438bde3a2e47964c29bfbc9417

seems to show that this line is essential.

Change History (3)

comment:1 Changed 7 years ago by Jörn Zaefferer

Status: newopen

Reproducable.

Preventing the default shouldn't have any effect on propagation.

comment:2 Changed 6 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 5 years ago by Scott González

Resolution: duplicate
Status: openclosed

Duplicate of #6642.

Note: See TracTickets for help on using tickets.