Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7963 closed bug (duplicate)

event.preventDefault() in UP and DOWN key codes of keydown.autocomplete

Reported by: charansunkara Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

In _create function of autocomplete, In case of keyCode.UP and keyCode.DOWN you are preventing the cursor movement using event.preventDefault().

And the comment is prevent moving cursor to beginning of text field in some browsers . You can prevent this only when menu is visible , In other case it's not required.

And your code works fine for single line case.But in case of multiple lines the issue occurs,As you are preventing the default behavior of the caret, The caret is not moving to the next or previous line when we press UP or DOWN arrow keys.

For keyCode.ENTER case you are doing the check like if ( self.menu.active ){ } . May be the same check for keyCode.UP and keyCode.DOWN will fix this bug

Thank you

Change History (2)

comment:1 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by Scott González

Duplicate of #7639.

Note: See TracTickets for help on using tickets.