Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8019 closed bug (duplicate)

It has long been seen by a bug. But it's still not fixed

Reported by: neoniks Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.draggable Version: 1.8.17
Keywords: Cc:
Blocked by: Blocking:

Description

There is a design

<script> 
	$( ".column" ).sortable({
            connectWith: ".column" ,
            containment:'.ppg',
            cursor: 'crosshair',
            revert: true,
            forceHelperSize: true,
            dropOnEmpty: true
        });
        $("#modmenu div.column_blok").draggable({
            connectToSortable:".column",
            helper: "clone",
            revert:true,
            dropOnEmpty: true,
            cursor:'point',
            appendTo: "body"
        });
        $( ".column" ).disableSelection();
</script>


<div id="modmenu">
	<div class="column_blok">text<div>
	<div class="column_blok">text<div>
	<div class="column_blok">text<div>
</div>

<div id="t1" class="column">
<table border="1" width="100%">
	<tr>
		<td width="50%"><div id="t2" class="column"><div></td>
		<td width="50%"><div id="t3" class="column"><div></td>
	</tr>
</table>
<div>

If you drag the div, from #modmenu in #t1 then everything is fine.

But if you then try to move the element moved from #t1 to #t3 for example. Then there is the problem! it is very difficult because the script is trying to shove movable div, and #t1 and #t3.

and during the most difficult to get into drag and drop #t3

Change History (2)

comment:1 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by Scott González

Duplicate of #8018.

Note: See TracTickets for help on using tickets.