Opened 10 years ago

Closed 10 years ago

#8031 closed bug (fixed)

Bad character in jquery.i18n.js (UI release 1.8.17 zip)

Reported by: regisc Owned by: regisc
Priority: minor Milestone: 1.8.17
Component: [meta] ui.build Version: 1.8.17
Keywords: Cc:
Blocked by: Blocking:

Description

/development-bundle/ui/i18n/jquery-ui-i18n.js contains a bad character (looks like a BOM) in the middle of the file. (look for "Dutch (Belgium)", bad char is just before the "/*")

Change History (9)

comment:1 Changed 10 years ago by Scott González

Owner: set to regisc
Status: newpending

Indeed. This was actually fixed last week with eee63a2e2435a6ecbcd0daa15f41b7bd5901e307. Did you just download this or did you download it a while ago? The 1.8.17 zips should be fixed. If they're not, please let me know where you got the bad zip from so we can fix it.

comment:2 Changed 10 years ago by regisc

Status: pendingnew

I downloaded the zip today from http://jqueryui.com/download/jquery-ui-1.8.17.custom.zip Thanks for looking into this.

comment:3 Changed 10 years ago by Scott González

Can you try now and verify whether it works for you?

comment:4 in reply to:  3 Changed 10 years ago by regisc

Replying to scott.gonzalez:

Can you try now and verify whether it works for you?

Redownloaded the zip (url from 2), opened in vim and looked for "Dutch":

    $.datepicker.setDefaults($.datepicker.regional['ms']);
});<feff>/* Dutch (Belgium) initialisation for the jQuery UI date picker plugin.
/* David De Sloovere @DavidDeSloovere */
jQuery(function($){

Note the "<feff>", so still not good.

comment:5 Changed 10 years ago by Scott González

This seems to be broken in places that should have been fixed already. I'm trying to figure out what's going on.

comment:6 Changed 10 years ago by Scott González

Ok, it looks like only the minified files were fixed. I'm going to manually fix the other source nl-BE and concatenated file in the SVN tag and then regenerate the quick download. That should fix all the problems with the download builder. I'll let you know when it's done.

comment:7 Changed 10 years ago by Scott González

Download should be working now. I tested with a custom download and the quick download, but would appreciate if you can confirm as well.

comment:8 Changed 10 years ago by regisc

=> Confirmed

Thanks

comment:9 Changed 10 years ago by Scott González

Milestone: 1.91.8.17
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.