Opened 8 years ago

Closed 7 years ago

#8039 closed bug (duplicate)

Sortable: Unable to drag item from one sortable with vertical scroll to other with vertical scroll

Reported by: alecs Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.8.17
Keywords: Cc:
Blocked by: Blocking:

Description

Here is my fiddle : http://jsfiddle.net/alecs/NFy3y/

Sometimes it's not possible to drag items from one scrollable div to other div.

Scroll down the left bar(to the lowest part of container) and try to drag item from the right bar to the left. Though when the left scroll is in the top position you are able to drag items to it.

Change History (4)

comment:1 Changed 8 years ago by tj.vantoll

_intersectsWith returns false in this situation when the item is in the container. In the method there are negative values for the top and bottom of the item, and the logic to determine isOverElement appears to be expecting positive values. So I'm assuming that's a problem.

I found that if I comment out this check in refreshPositions everything works:

//We ignore calculating positions of all connected containers when we're not over them
if(item.instance != this.currentContainer && this.currentContainer && item.item[0] != this.currentItem[0])
    continue;

So it appears to be related to the position not being recalculated when it should be.

comment:2 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 7 years ago by petersendidit

Status: newopen
Summary: Unable to drag item from one sortable with vertical scroll to other with vertical scrollSortable: Unable to drag item from one sortable with vertical scroll to other with vertical scroll

comment:4 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: openclosed

Duplicate of #7065.

Note: See TracTickets for help on using tickets.